实验拓扑
实验需求
本实验模拟家庭网络通过运营商宽带接入互联网的场景。
一、家庭网络
家庭网关路由器使用 AR201 模拟,E0/0/1-7 均为 LAN 口,E0/0/8 为 WAN 口。 完成以下需求:
1.1 配置 PC 网关 vlanif1,地址为 192.168.3.1/24
1.2 启动 DHCP 功能,采用接口地址池,为 PC 自动分配地址。
1.3 确认 PC1/2 均可自动获取 IP 地址,并可与网关通信。
命令配置
Home_GW
dhcp enable
#开启 dhcp 功能
interface Vlanif1
ip address 192.168.3.1 255.255.255.0
dhcp select interface
#LAN 口默认 VLAN1,配置网关,启用 DHCP 接口地址池。
PC1 获取到地址 192.168.3.254/24,并可与网关通信。
二、ISP 网络
ISP 路由器和光猫均用 AR2220 模拟,完成以下需求:
2.1 ISP 路由器是 PPPoE 服务端。
2.1.1 创建本地地址池,名称自取。地址范围 100.1.1.0/24,网关 100.1.1.1。
2.1.2 创建虚拟面板 0,IP 地址 100.1.1.1/24;使用 CHAP 认证;调用本地地址池为对端分配 IP 地址。
2.1.3 物理接口启用 PPPoE,关联虚拟面板。
2.1.4 使用 AAA,创建域 spoto;用户名 hcia@spoto,密码自定义,服务 ppp。
PPPoE服务端命令配置
ip pool 1
gateway-list 100.1.1.1
network 100.1.1.0 mask 255.255.255.0
#
interface Virtual-Template0 \\创建虚拟面板
ppp authentication-mode chap \\启用 chap 认证
remote address pool 1 \\分配远端地址
ip address 100.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/0
pppoe-server bind Virtual-Template 0
#
aaa
domain spoto
local-user hcia@spoto password cipher 123
local-user hcia@spoto service-type ppp
#
2.2 ISP 光猫是 PPPoE 客户端。
2.2.1 创建拨号接口 0,使用 CHAP 认证;用户名密码同 2.1.4;IP 地址由对端分配。
2.2.2 启用拨号功能,名称 hcia,绑定拨号 ID 100。
2.2.3 网络侧物理接口关联拨号 ID 100。
2.2.4 配置默认路由。
2.2.5 确认拨号成功可以获取 IP 地址。
2.2.6 确认可以 ping 通 ISP 路由器的环回口 114.114.114.114。
interface Dialer0 \\创建拨号接口
link-protocol ppp \\使用 PPP 协议
ppp chap user hcia@spoto \\用户名
ppp chap password cipher 123 \\密码
ip address ppp-negotiate \\PPP 协商地址
dialer user hcia \\启用拨号功能
dialer bundle 100 \\绑定拨号 ID 为 100
#
interface GigabitEthernet0/0/0
pppoe-client dial-bundle-number 100
#
ip route-static 0.0.0.0 0.0.0.0 Dialer 0
三、家庭网络接入 ISP 家庭网关与 ISP 光猫互联,完成家宽接入。
3.1 ISP 光猫部署 DHCP 和 NAT
3.1.1 用户侧接口配置静态 IP 地址:192.168.0.1/24。
3.1.2 启用 DHCP 接口地址池。
3.1.3 部署 easy-ip。
dhcp enable
#
interface GigabitEthernet0/0/1
ip address 192.168.0.1 255.255.255.0
dhcp select interface
#用户侧物理接口启用 DHCP
acl number 2000
rule 5 permit
#
interface Dialer0
nat outbound 2000
#在拨号接口上启用 easy-IP
3.2 家庭网关配置 WAN 口
3.2.1 WAN 口使用 DHCP 自动获取 IP 地址。
3.2.2 确认成功获取 IP,同时获取默认路由。
3.2.3 部署 easy-ip。
3.2.4 确认 PC1/2 可以 ping 通 114.114.114.114.
acl number 2000
rule 5 permit
#ACL 编号不限
interface Ethernet0/0/8
nat outbound 2000
ip address dhcp-alloc
#WAN 口使用 nat。
检查配置和测试连通性
标签:ip,ISP,HCIA,拨号,地址,IP,interface,PPPoE From: https://blog.csdn.net/weixin_59151049/article/details/142613421